ABBYY FineReader Tutorial

ABBYY Software House

ABBYY FineReader
Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры
Советы

Как ввести документ за минуту

Процесс ввода документов в компьютер состоит из четырех этапов: сканирование, распознавание, проверка и сохранение результатов распознавания. Для того чтобы быстро распознать документ, просто нажав одну кнопку, воспользуйтесь сценарием ABBYY FineReader, командой Сканировать и распознать или Открыть и распознать или запустите Мастер Scan&Read, который поможет вам выбрать настройки и обработать документ.

Распознавание бумажных документов

  1. Убедитесь в том, что ваш сканер включен.
     Внимание! Многие модели сканера необходимо включать до включения компьютера.
  2. Вставьте в сканер страницу, которую вы хотите распознать.
  3. Нажмите на стрелку справа от кнопки Scan&Read, и в открывшемся локальном меню выберите один из пунктов:
Scan&Read Button

  • Мастер Scan&Read запускает специальный режим сканирования и распознавания, во время которого система подсказывает пользователю, что надо делать, чтобы получить тот или иной результат.

  • Сканировать и распознать позволяет отсканировать бумажный документ и распознать полученное изображение.

  • Сканировать в PDF позволяет отсканировать бумажный документ, распознать полученное изображение и передать распознанный текст в новый документ Adobe Acrobat/Reader.

  • Сканировать в Word позволяет отсканировать бумажный документ, распознать полученное изображение и передать распознанный текст в новый документ Microsoft Word.

Обработка файлов изображений и PDF документов

Вы также можете открыть файл изображения (или PDF файл) и распознать его с помощью команд локального меню кнопки Scan&Read:

  • Открыть и распознать позволяет открыть файл изображения или PDF документ и распознать его.

  • PDF/изображение в Word позволяет открыть файл изображения или PDF документ, распознать изображение и передать распознанный текст в новый документ Microsoft Word.
office@abbyy.com
© 1996-2005 ABBYY Software


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры
Советы

Советы

  • Параметры сканирования

    Используйте разрешение 300 dpi для стандартных текстов (размер шрифта 10pts. и больше) и разрешение 400-600 dpi для текстов с меньшим шрифтом (9pts. и меньше). Сканирование в сером режиме рекомендуется для повышения качества распознавания. При сканировании в сером режиме яркость регулируется автоматически. Если вы хотите, чтобы диалог Настройки сканера открывался каждый раз перед сканированием при работе в режиме Использовать интерфейс ABBYY FineReader, отметьте опцию Запрашивать опции перед началом сканирования на закладке Сканировать/Открыть диалога Сервис>Опции.

  • Открытие файлов изображений или пакетов ABBYY FineReader непосредственно из Windows Explorer

    Щелкните правой кнопкой мыши на значке файла изображения или на пакете ABBYY FineReader, который вы хотите открыть, и выберите в локальном меню опцию Открыть с помощью ABBYY FineReader.

  • Анализ оформления страницы

    Анализ оформления страницы может проходить как вручную, так и автоматически. В большинстве случаев программа ABBYY FineReader сама выполняет сложную задачу анализа страницы. Нажмите кнопку 2-Распознать для запуска автоматического анализа оформления страницы. Распознавание и анализ страницы выполняются одновременно.
    Если программа выделила некоторые блоки неправильно, проще и быстрее редактировать неправильно размеченные блоки, используя инструмент для редактирования блоков, чем удалять блоки и выделять их заново вручную.
    В некоторых случаях качество автоматического анализа страницы может быть улучшено с помощью изменения опций анализа оформления страницы. Для просмотра текущих опций страницы откройте закладку Распознать диалога Опции (меню Сервис).

  • Использование шаблонов блока

    Если вы обрабатываете большое количество документов с одинаковым оформлением страницы, вы можете создать шаблон блоков (меню Изображение>Сохранить шаблон блоков...) (т.е. стандартный набор блоков, соответствующих оформлению страницы вашего документа) и применить этот шаблон ко всем страницам с одинаковым оформлением, которые вы хотите распознать (меню Изображение>Загрузить шаблон блоков...).

  • Улучшение качества распознавания изображений сдвоенных страниц

    Чтобы увеличить качество распознавания, разбейте сканируемые изображения так, чтобы каждой из пары сдвоенных страниц на изображении соответствовала отдельная страница пакета. Изображения могут быть разбиты как автоматически, так и вручную.

    Чтобы разбивать изображения автоматически перед добавлением в пакет, отметьте опцию Делить разворот книги в диалоге Опции на закладке Сканировать/Открыть. Чтобы разбивать изображения вручную, отметьте опцию Разбить изображение... в меню Изображение... Устранение искажений, анализ оформления страницы и распознавание будут проходить отдельно для каждой страницы.

  • Скорость распознавания

    Скорость распознавания зависит от различных параметров: скорости процессора, размера RAM, типа изображения и т.д.
    Если вам нужно обработать большое количество документов с простым оформлением и хорошим качеством печати и сканирования, вы можете использовать специальный режим распознавания - распознавание в быстром режиме. Для того чобы включить этот режим, откройте закладку Распознать диалога Опции (меню Сервис>Опции) и отметьте опцию Быстрый в группе Режим распознавания.
    На многопроцессорных машинах скорость распознавания больших пакетов можно увеличить, включив режим "Фоновое распознавание" (только для версии Corporate Edition).

  • Полнотекстовый поиск в распознанных документах

    Единицей поиска может быть одно или несколько слов. Вы можете выполнять поиск слов во всех словоформах по всем распознанным страницам. Для этого выберите пункт Расширенный поиск в меню Правка или нажмите ALT+F3.

  • Неправильно отображаемые символы

    Если в окне Текст программы ABBYY FineReader символы отображаются неправильно (например, "?" или "□" на месте некоторых букв), это означает, что текущий шрифт не поддерживает полностью алфавит выбранного вами языка распознавания. Выберите шрифт, который поддерживает все символы текста распознаваемой страницы (например, Arial Unicode или Bitstream Cyberbit) на закладке Сохранить (меню Свойства>Опции) в группе Шрифты, и распознайте документ заново.

  • Редактирование распознанного текста в Microsoft Word

    Если вы предпочитаете редактировать распознанный текст в Microsoft Word, а не в текстовом окне программы ABBYY FineReader, вы можете сделать так, чтобы неуверенно распознанные символы остались подсвеченными. На закладке RTF/DOC/Word XML диалога Форматы в группе Текст отметьте опцию Выделять неуверенно распознанные символы. Для выделения неуверенно распознанных символов будет использован тот же цвет, которым эти символы выделяются в окне Текст ABBYY FineReader. Цвет, используемый для выделения неуверенно распознанных символов, можно изменить на закладке Вид диалога Опции (меню Сервис>Опции).

  • Уменьшение размера документа

    Если распознанный документ содержит много картинок, вы можете уменьшить размер этого документа при сохранении в RTF, DOC, Word XML, PDF, HTML, или PPT-формат: выберите нужные качество и формат для иллюстраций в группе Картинки на соответствующих закладках диалога Форматы.

  • Редактирование гиперссылок

    ABBYY FineFeader 8.0 находит на изображениях гиперссылки на файлы, протоколы, веб-сайтф и адреса электронной почты. Программа распознает текст и восстанавливает адрес гиперссылок в выходном документе. Все найденные гиперссылки выделяются синим цветом и подчеркиванием. Цвет выделения гиперссылок можно изменить в диалоге Опции на закладке Распознать.

  • Сохранение настроек пакета

    Чтобы сохранить установки пакета в файл, нажмите кнопку Сохранить опции на закладке Общие (меню Сервис>Опции). Откроется диалог Сохранить опции как. Введите имя файла. Будут сохранены установки следующих закладок диалога: Распознать, Сканировать/Открыть, Сохранить и Проверить, а также Форматы... Группы пользовательских языков и эталонов также будут сохранены в этом файле.

  • Пользовательские языки и группы языков

    В дополнение к встроенным языкам и группам языков Вы можете создать и новый язык или новую языковую группу (из языков, поддерживаемых программой ABBYY FineReader) и использовать его(ее) для распознавания.

  • Настройка панелей инструментов ABBYY FineReader

    Вы можете добавлять/удалять кнопки, обеспечивающие доступ к тем или иным командам программы, на/с панелей инструментов Стандартная, Изображение и Форматирование в диалоге

    Настройка (меню Сервис>Настройка).

  • Документ с темными полями

    Иногда в результате сканирования по краям изображения появляются зачерненные поля. В таком случае перед распознаванием можно выполнить обрезку изображения, удалив ненужные фрагменты. Для того чтобы обрезать изображение:

    1. В меню Изображение выберите команду Обрезать изображение.
    2. Изображение будет открыто в окне Обрезать изображение, контур изображения будет выделен черной линией.
    3. потяните мышью черную линию, обрамляющую изображение, или маркеры, находящиеся в углах контура изображения. Часть изображения, которая будет отрезана, выделяется серым цветом. Щелкните по кнопке Обрезать.

    С помощью инструмента обрезки изображения можно также получить изображение стандартного размера (соответствующего одному из стандартных форматов, например, А4, А5). Для того чтобы сделать это, выберите нужный размер бумаги в выпадающем списке Привести к и нажмите на кнопку Обрезать.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Работа с различными типами документов

Данный раздел является "практическим руководством" по работе с программой ABBYY FineReader. Информация, содержащаяся в этом разделе, поможет Вам улучшить качество распознавания документов при работе с программой. Вы узнаете, как избежать некоторых типичных проблем при сканировании и распознавании, таких как: ошибки при сканировании, неверно заданные параметры сканирования/распознавания и т.д. В разделе "Примеры" содержатся подсказки и дополнительная полезная информация о сканировании и распознавании определенных типов сложных документов, например, таблиц, журнальных статей и т.д. Вы узнаете о возможных причинах возникновения ошибок и ухудшения качества распознавания, а также о том, как избежать и/или устранить эти проблемы. В дополнение, этот раздел предлагает информацию об использовании некоторых дополнительных функций программы FineReader, обеспечивающих лучшее качество распознавания текстов.
Надеемся, что данный раздел окажется хорошим подспорьем для Вас при работе с программой!

Чтобы ознакомиться с основными опциями программы ABBYY FineReader, см. Руководство пользователя или Справку.

Типы документов:

  1. Простое письмо (неправильно подобранные параметры сканирования)
  2. Многоязычный документ
  3. Книжный разворот
  4. Факсы и другие документы с низким качеством печати
  5. Сложная журнальная страница
  6. Газетная страница
  7. PDF документ
  8. Работа с таблицами
    • Простая таблица
    • Таблица с неполным количеством черных разделителей
    • Сложная таблица
  9. Работа с визитными карточками
  10. Работа с презентациями PowerPoint
  11. Программная распечатка
  12. Документ, использующий декоративный шрифт
  13. Документ с артикулами (создание нового языка)
  14. Фотография документа

Где найти картинки, о которых идет речь в разделе "Обучение на примерах"?


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Работа с визитными карточками

(Cards.tif)

Одним из веяний нашего времени стали визитные карточки. Вы получаете их не только от партнеров по бизнесу, но и от друзей, знакомых. Конечно, это очень удобно - вся важная информация о человеке сконцентрирована на листке бумаги небольшого формата. Но иногда пугает их количество, и мы тратим массу времени для того, чтобы их упорядочить, привести в систему, найти удобное средство хранения.

Мы предлагаем вам простой и удобный способ ввода и хранения визиток в компьютере с помощью программы ABBYY FineReader. Все визитки обрабатываются и хранятся в пакете программы. Используя функцию полнотекстового поиска по распознанным страницам пакета, вы можете найти нужную визитку (при этом поиск возможен по любой распознанной информации с визитки - по названию компании, фамилии, телефону и т.д.). Список найденных визиток показывается в окне Поиск . Чтобы открыть визитку, выберите запись в результатах поиска.
Вы можете пополнять пакет новыми визитками, редактировать уже распознанные визитки в окне Текст.

  1. Положите несколько визитных карточек (столько, сколько уместится) в сканер.

    Внимание! Визитки должны быть разложены так, чтобы в результате была получена "табличная структура". Между рядами и колонками должно быть некоторое расстояние. Допустимо либо горизонтальное (более длинные стороны визиток расположены вдоль горизонтали), либо вертикальное размещение визиток на листе, но не оба сразу.

    Установите следующие параметры сканирования:

    • разрешение - 400-600 dpi (обычно визитные карточки содержат текст, набранный мелким шрифтом, для хорошего распознавания которого требуется отсканировать документ с более высоким разрешением вместо обычных 300 dpi).
    • тип изображения - серый или цветной.

    Нажмите кнопку 1-Сканировать.

  2. Для повышения качества распознавания полученные изображения с визитками следует разделить так, чтобы каждой визитке соответствовала отдельная страница пакета. В этом случае исправление перекоса строк, анализ и распознавание будет проводиться для каждой визитки.
    Для этого в меню Изображение выберите пункт Разбить изображение . В открывшемся диалоге Разбить изображение нажмите кнопку [image], а затем кнопку ОК . В окне Пакет появятся новые страницы: каждая страница будет содержать изображение одной визитки. При этом исходное изображение (содержащее несколько визиток) будет удалено из пакета.

    Замечание : Если изображение было поделено на визитки неверно, то попробуйте поделить изображение вручную. Для этого воспользуйтесь кнопками [image] и [image]. Чтобы передвинуть или удалить разделитель, нажмите кнопку Выбор разделителя - [image], мышью переместите разделитель в нужное место. Для удаления разделителя переместите его за границы изображения. Чтобы удалить все разделители, нажмите кнопку [image].

  3. Установите язык распознавания. Если требуется, установите несколько языков распознавания. При этом помните, что увеличение количества подключенных к распознаванию одного документа языков может привести к ухудшению качества распознавания. Не рекомендуется подключать более 2-3 языков. Перед запуском распознавания проверьте подключенные на закладке Сохранить шрифты: они должны содержать все символы языка распознавания. В противном случае распознанный текст будет неправильно отображен в окне Текст (в словах на месте некоторых букв стоят значки "?" или "?").

    Нажмите кнопку 2-Распознать .


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Сложная таблица

Описание ситуации: неправильный анализ таблиц со сложной нерегулярной структурой: неправильное разделение таблицы на строки и столбцы; неправильное выделение картинок в ячейках таблицы; плохое распознавание вертикального и инвертированного текста.

(TableDif.tif)

Решение : Воспользуйтесь инструментами ручной разметки таблиц, расположенными на панели Изображение :

- чтобы добавить вертикальную линию;

- чтобы добавить горизонтальную линию;

- чтобы удалить линию.

Для ячеек таблицы, содержащих только картинки, в диалоге Свойства блока (меню Вид > Свойства ), отметьте пункт Считать ячейку картинкой .

Для выделения картинок внутри ячеек с текстом в отдельные блоки, воспользуйтесь инструментом на панели Изображение : .

Для ячеек таблицы, содержащих вертикальный текст, в диалоге Свойства блока (меню Вид > Свойства ) в поле Направление текста укажите направление текста в ячейке; для ячеек с инвертированным текстом (светлый текст на темном фоне) в выпадающем списке Инверсия текста выберите пункт Инвертирован.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Книжный разворот

Описание ситуации: за одно сканирование сканируется пара страниц (книжный разворот), при этом каждая страница имеет свой угол наклона, что отрицательно сказывается на качестве распознавания, кроме того обе страницы сохраняются на одну страницу в две колонки.

Book: duall pages

(DualPage.tif)

При распознавании изображение должно иметь стандартную ориентацию: текст должен читаться сверху вниз, и строки должны быть горизонтальными. По умолчанию при распознавании программа автоматически определяет и корректирует ориентацию изображения. У изображений со сдвоенными страницами стандартная ориентация отсутствует, так как каждая страница имеет свой угол наклона.

Решение : В программе существует специальный режим, при котором изображение со сдвоенными страницами разрезается на две части и превращается в две отдельные страницы пакета. Это позволяет обработать каждую страницу: автоматически исправить угол наклона и сохранить распознанный текст с каждой страницы в отдельный файл (или на отдельную страницу).

  • Чтобы установить данный режим, перед добавлением изображения в пакет на закладке Сканировать/Открыть в группе Обработка изображений отметьте опцию Делить разворот книги.

Разрезать изображение со сдвоенными страницами на две части, которые впоследствии будут преобразованы в две отдельные страницы пакета, можно также с помощью опции Разбить изображение . Подробную информацию о работе данной опции вы можете найти в разделе "Работа с визитными карточками".


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Факсы и другие документы с низким качеством печати

Описание ситуации: плохое качество печати документа (много "мусора" на изображении, нечеткие границы букв, угловатые, неровные буквы с дефектами, перекос строк, смещение и неявные границы черных разделителей таблиц).

Fax (document of poor quality)

(Fax.tif)

Решение: Для повышения качества распознавания данного документа его необходимо сканировать в сером режиме. В этом случае вам не нужно будет подбирать яркость сканирования - программа сделает это за вас автоматически.

В случае сложной структуры документа также рекомендуется разбивать его на блоки вручную или контролировать процесс автоматического разбиения.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Программная распечатка

Описание ситуации: данный пример имеет две особенности, влияющие на качество распознавания:

  • программа передает отступы от левого края листа не пробелами, а с помощью задания отступов абзаца; при экспорте в .txt левый отступ не сохраняется; некоторые строки объединяются в один абзац и при экспорте объединяются в одну строку;
  • много ошибок при распознавании конструкций языков программирования.

(listing.tif)

Решение:

  1. Для распознавания таких документов существует специальная опция программы Распознать как форматированный пробелами текст. Отметьте эту опцию в диалоге Дополнительные опции в группе Распознать. Для того чтобы открыть этот диалог, нажмите кнопку Дополнительные опции на закладке Общие диалога Опции (меню Сервис>Общие).
    В этом случае в распознанном тексте сохранится деление на строки; отступы от левого края будут переданы пробелами; каждая строка выделена в отдельный абзац, а расстояния между абзацами переданы пустыми строками. Все это позволит сохранить исходное форматирование текста при сохранении в формате Txt.
  2. Для хорошего распознавания распечаток программ требуется установить специальный язык распознавания. Для этого:
    • В списке языков на панели Стандартная выберите значение Выбор из полного списка языков и в открывшемся диалоге Язык распознаваемого текста выберите пункт C++.
    Замечание. Если распознаваемая программная распечатка помимо программного кода содержит текстовые комментарии, то для хорошего распознавания необходимо выбрать несколько языков распознавания: язык программирования и язык, на котором написаны комментарии.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Где найти картинки, о которых идет речь в разделе "Обучение на примерах"?

Все изображения находятся в папке Tutorial на установочном диске ABBYY FineReader.

Для удобства работы с данным разделом мы рекомендуем создать новый пакет и добавить в него демонстрационные изображения.

Для этого:

  1. В меню Файл выберите пункт Новый пакет .
  2. Чтобы добавить изображения в созданный пакет, в меню Файл выберите пункт Открыть PDF/изображение... или нажмите CTRL+O . В открывшемся диалоге выберите изображения. Чтобы выбрать все изображения сразу, нажмите CTRL+A . Изображения будут добавлены в открытый пакет, а их копии сохранены в папке пакета.
  3. Чтобы сохранить новый пакет, выберите пункт Сохранить пакет как... в меню Файл . В открывшемся диалоге укажите имя созданного пакета и место его хранения на диске.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Сложная журнальная страница

Описание ситуации: плохое качество распознавания вследствие неправильного выделения блоков.

(Magazin.tif)

Решение : В результате автоматического анализа данной страницы были выделены лишние блоки (например, участки текста на картинке). Проверьте количество блоков, а также отредактируйте форму выделенных блоков.

Для этого воспользуйтесь инструментами на панели Изображение :

  • - чтобы удалить выделенные на картинке лишние блоки текста;
  • и [image] - чтобы нарисовать блоки непрямоугольной формы;
  • и [image] - чтобы нарисовать текстовый блок и блок-картинку.

Замечание. При выделении текстовых блоков следите за тем, чтобы границы блоков совпадали с границами текста.

Более подробно о выделении и редактировании блоков вручную см. в разделе "Выделение и редактирование блоков вручную".


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Многоязычный документ

Описание ситуации: на одной странице встречается несколько языков распознавания.

(Manylang.tif)

Для распознавания данного документа необходимо выбрать несколько языков распознавания. Для этого:
  • В списке языков на панели Стандартная выберите пункт Выбор нескольких языков и в открывшемся диалоге Язык распознаваемого текста укажите Английский, Французский и Немецкий языки.

Замечание. Увеличение количества подключенных к распознаванию одного документа языков может привести к ухудшению качества распознавания. Не рекомендуется подключать более 2-3 языков.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Документ с артикулами (создание нового языка)

Описание ситуации: большое количество ошибок при распознавании артикулов.

Document with article codea

(NewLang.tif)

При распознавании программа опирается на знание о языке, указанном в качестве языка распознавания. Она использует словарь (проверяет слова по словарю), морфологическую модель языка, правила написания текста. При обработке текстов, содержащих много неестественных конструкций, например, артикулы, программа распознает их посимвольно, не используя дополнительной информации о построении данных конструкций, что увеличивает вероятность возникновения ошибок распознавания.

Решение : Перед распознаванием данного документа необходимо создать новый язык: артикулы (Codes).

Чтобы создать новый язык распознавания:

  1. В меню Сервис выберите пункт Редактор языков ... и нажмите кнопку Новый. В открывшемся диалоге установите переключатель в положение Создать новый язык на основе существующего и выберите язык, на основе которого Вы создаете новый: в данном случае Английский.
  2. Откроется диалог Свойства языка .

При создании нового языка нужно определить следующие параметры (все параметры задаются в диалоге Свойства языка):

  1. Имя нового языка - Codes.
  2. В поле Алфавит языка указан алфавит языка, на основе которого Вы создаете новый язык. Нажмите кнопку [image], чтобы отредактировать алфавит.

    В нашем случае алфавит языка должен содержать следующие символы: .0123456789BDFGLRW

  3. Словарь, который будет использоваться системой при распознавании и проверке распознанного текста.

    В данном случае мы создадим пользовательский словарь на основе регулярного выражения. Для этого в группе Словарь установите переключатель в положение Регулярное выражение и введите следующее регулярное выражение:

    DRG|(B[0-9][0-9]|22.5)|(L[0-9])|(F[0-9][0-9][0-9])|(W([0-9]+)) Более подробно о написании регулярных выражений см. Регулярные выражения.

Далее следует подключить данный язык к распознаванию: для всего документа установите Английский язык распознавания (выберите его из списка языков на панели Стандартная ), а для колонки с артикулами - новый язык - Codes. Чтобы установить свой язык распознавания на колонку таблицы:

  • Выделите необходимую колонку, щелкните правой кнопкой мыши и в локальном меню выберите пункт Свойства . В открывшемся диалоге Свойства на закладке Блок в поле Язык распознавания укажите соответствующий язык распознавании и в группе Применить к установите переключатель в положение Выделенным ячейкам.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Газетная страница

Описание ситуации: плохое качество распознавания вследствие особенностей газетной бумаги (желтая, с ворсинками и др.), "мусора" на изображении, неправильного выделения блоков.

(Newspaper.tif)

Для повышения качества распознавания газетной страницы ее рекомендуется сканировать в сером режиме. Серый тип изображения обеспечивает более высокую степень сохранения информации о буквах сканируемого текста, что приводит к улучшению качества распознавания документов среднего и низкого качества печати.

Газетные страницы представляют собой многоколоночный текст с картинками, некоторые участки которого могут располагаться поверх картинки, что иногда может привести к неправильному выделению блоков при автоматическом анализе. О том, что делать в случае неправильного выделения блоков, подробно написано в разделе "Сложная журнальная страница".


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

PDF документ

(PDF.pdf)

 Одним из наиболее популярных форматов представления электронных документов в Internet, архивах и т.д. является формат PDF ( Portable Document Format ).

Программа ABBYY FineReader поможет вам распознать PDF документы и сохранить распознанный текст в выбранный вами формат или передать его во внешнее приложение.

С помощью ABBYY FineReader вы также можете распознать изображение и сохранить текст в PDF файл. Выбор типа PDF файла зависит от того, как вы собираетесь использовать созданный PDF документ в дальнейшем:

  • Только текст и картинки
    Сохраняется только распознанный текст и картинки в нем. Возможен поиск по тексту. Размер PDF-файла невелик. Режим оптимален для документов с текстом и картинками на белом фоне (контракты, страховые полисы, письма, факсы).

  • Только изображение
    В данном файле сохраняется точное изображение страницы. Полученный документ неотличим от оригинала, но поиск по тексту невозможен. Режим рекомендуется для пересылки по электронной почте точных копий счетов, сертификатов и других документов.

  • Текст поверх изображения страницы
    Сохраняется фон и картинки первоначального документа, поверх которых накладывается распознанный текст. Данный тип PDF файлов оптимален для документов с текстом на цветном фоне (рекламные буклеты, брошюры).

  • Текст под изображением страницы
    Сохраняется точное изображение первоначального документа, под которым сохраняется распознанный текст. Полученный документ неотличим от оригинала, и в нем возможен поиск по тексту.

Чтобы установить режимы сохранения в формате PDF:

  1. Щелкните по кнопке Форматы на закладке Сохранить в диалоге Опции (меню Сервис>Опции) или нажмите Ctrl+Shift+X.
  2. На закладке PDF диалога Форматы установите требуемый режим.

PDF является распространенным форматом для пересылки документов по электронной почте или публикации документов на веб-сайтах. Естественно, что при публикации на веб-сайтах очень важна высокая скорость открытия документов. Документ, сохраненный из программы ABBYY FineReader в формате PDF, отвечает подобным требованиям. Структура PDF такова, что позволяет открывать в пользовательском браузере для просмотра первые страницы PDF документа, не дожидаясь, когда весь файл целиком будет загружен с веб-сервера.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Фотография документа

Описание ситуации: низкое качество распознавания изображения.

Качество распознавания может быть низким вследствие низкого качества изображения. Для успешного распознавания необходимы изображения хорошего качества. Сделайте новую фотографию документа, если:
  • Снимок слишком темный и неконтрастный.
    Решение: Постарайтесь улучшить освещение. Если такой возможности нет – установите меньшее значение диафрагмы.
  • Снимок нерезкий.
     Решение: Возможно, автофокус плохо срабатывает из-за отсутствия света. Попробуйте улучшить освещение. Если это не помогает, используйте ручную фокусировку.

    Если нерезкая только часть снимка – попробуйте выставить большее значение диафрагмы. Снимайте с большего расстояния при максимальном оптическом увеличении. Наводите фокус на точку, расположенную между центром и краем изображения.

  • Вспышка создает пересвеченную область в центре кадра.
     Решение: Отключите вспышку. Если нет возможности использовать другие источники света, снимайте с большего расстояния.
  • Строки текста искажаются по краям изображения.
    Решение    : Отметьте опцию Устранить искажение срок в диалоге Опции на закладке Сканировать/О ткрыть (меню Сервис>Опции).

Подробнее о том, как выбрать режим работы фотоаппарата и получить снимок документа, пригодный для распознавания текста, см. в разделе "Съемка текстов фотоаппаратом".


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Работа с презентациями PowerPoint

(HandOuts.tif)

Одним из популярных средств создания современных презентаций является программа Microsoft PowerPoint. Презентация состоит из слайдов, наглядно и информативно представляющих материал. Слайды презентаций, как правило, распечатываются на одном или нескольких листах бумаги и раздаются участникам для улучшения восприятия и усвоения информации, а также внесения каких-то заметок, возникающих в ходе презентации, или пояснений.

Возможно, вернувшись с подобного рода презентации, вы захотите перевести имеющиеся у вас распечатки слайдов в электронный вид. Обычно на одном листе расположены 3-6 кадров презентации, распознавание которых может быть затруднено из-за мелкого шрифта текста слайдов.

Для повышения качества распознавания документа с презентацией рекомендуется:

  1. В случае мелкого шрифта отсканировать документ с более высоким разрешением - 400 -600 dpi (вместо обычных 300 dpi).
  2. После того как изображение с презентацией отсканировано, разрезать его таким образом, чтобы каждому слайду соответствовала отдельная страница пакета. Для этого в меню Изображение выберите пункт Разбить изображение . В открывшемся диалоге Разбить изображение нажмите кнопку [image], а затем кнопку ОК . В окне Пакет появятся новые страницы: каждая страница будет содержать изображение одного слайда. При этом исходное изображение с презентацией будет удалено из пакета. Подробную информацию о том, как разрезать изображение на несколько частей, Вы можете найти в разделе " Работа с визитными карточками ".
  3. Далее вы можете обработать каждый слайд презентации в отдельности по аналогии с другими документами; это можно сделать вручную или автоматически.
После того как страницы с изображением каждого слайда получены и обработаны, вы можете их распознать, отредактировать и сохранить результаты распознавания в любом из поддерживаемых форматов, в том числе в PowerPoint.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Простое письмо (неправильно подобранные параметры сканирования)

Как правило, документы простой структуры не требуют специальной установки опций сканирования и распознавания. Настройка дополнительных опций необходима только в том случае, если:

  • размер шрифта документа слишком мелкий;
  • неправильно подобрана яркость сканирования.
Simple letter (incorrect scanning parameters)

(Font_300.tif)
  1. Мелкий шрифт
    Для хорошего распознавания мелкого шрифта документ необходимо отсканировать с более высоким разрешением - 400 -600 dpi (вместо обычных 300 dpi).

    Сравните результаты сканирования одного и того же документа с разными значениями разрешения (просмотрите полученные изображения в окне Крупный план в масштабе С точностью до пиксела , меню Вид > Окно Крупный план > Масштаб):

    300 dpi ( Font_300.tif ) 600 dpi ( Font_600.tif )

  2. Неправильно подобранная яркость сканирования
    При распознавании изображения Font_300.tif возникает сообщение "Увеличьте яркость сканирования, чтобы сделать изображение светлее". Это сообщение вызвано неправильно подобранной яркостью сканирования.

    Для хорошего распознавания отсканированное изображение должно быть четким и удобочитаемым. В нашем случае изображение содержит множество дефектов - лишних точек и склеек букв. Просмотрите изображение в окне Крупный план :

    - так выглядит Font_300.tif в окне Крупный план.
    - пример хорошего (в смысле распознавания) изображения.

    Подробнее о настройке яркости см. "Советы по подбору яркости".

Решение : Увеличьте яркость сканирования (сделайте изображение светлее) или отсканируйте изображение в сером режиме (в этом случае яркость подбирается автоматически). Увеличьте разрешение до 600 dpi. Результат применения этих действий можно увидеть, открыв и распознав Font_600.tif .


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Простая таблица

(Table.tif)

 Если изображение отсканировано с правильными параметрами и таблица имеет простую структуру (есть все черные разделители, таблица не содержит картинок, нет инвертированного или вертикального текста), то ее распознавание не требует установки каких-либо специальных опций.


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Таблица с неполным количеством черных разделителей

Описание ситуации: все строки таблицы между черными горизонтальными линиями (разделителями) объединены в одну строку таблицы.

Table without black separators

(TableSep.tif)

Если в таблице встречается смешанное разделение на строки и столбцы, при котором некоторые строки разделены черными разделителями, а некоторые нет, программа может разбить таблицу на строки неправильно.

Решение : Программу можно "заставить" выделять каждую строку текста в отдельную строку таблицы. Для этого:

  • В группе Распознать диалога Дополнительные опции отметьте опцию В каждой ячейке таблицы не более одной строки текста. Для того чтобы открыть этот диалог, нажмите кнопку Дополнительные опции на закладке Общие в диалоге Опции (меню Сервис>Опции).


Обучение на примерах содержит описание возможностей программы, улучшающих качество распознавания документов различных типов

Быстрое знакомство
Примеры
Советы
Содержание
Быстрое знакомство
Примеры

Простое письмо

Многоязычный документ

Книжный разворот

Факсы

Сложная журнальная страница

Газетная страница

PDF документ

Простая таблица

Таблица с неполным количеством черных разделителей

Сложная таблица

Работа с визитными карточками

Работа с презентациями PowerPoint

Программная распечатка

Документ, использующий декоративный шрифт

Документ с артикулами

Фотография документа

Советы

Документ, использующий декоративный шрифт

Описание ситуации : много ошибок при распознавании.

Document with decorative font

(Training.tif)

Программа обучена распознаванию стандартных шрифтов и не предназначена для распознавания декоративных шрифтов, например, FuturisXShadowC, ParagmaticaShadowC, CyrillicGoth.

Решение : Для повышения качества распознавания данного документа воспользуемся специальным режимом распознавания: распознавание с обучением . Обычно в данном режиме распознаются 1-2 страницы, в результате чего создается пользовательский эталон, который в дальнейшем подключается для распознавания остальных страниц. При этом важно помнить, что с озданный эталон можно использовать только для распознавания текстов, использующих тот же шрифт и размер шрифта и отсканированных с тем же разрешением, что и документ, на основе которого данный эталон создавался.

  1. Выделите блоки на изображении (меню Процесс > Распознать > Анализ макета страницы или [image]).
  2. Установите режим Распознавание с обучением (на закладке Распознать, меню Сервис>Опции в группе Распознавание с обучением установите переключатель в положение Распознавание с обучением). В строке состояния появится название эталона (по умолчанию default).
  3. Установите язык распознавания (Английский).
  4. Нажмите кнопку 2-Распознать.
  5. Обучите эталон, распознав страницу в режиме распознавания с обучением.
    Обучаемые символы заносятся в эталон, создаваемый системой по умолчанию. По окончании обучения система сохранит созданный эталон (default.ptn) в папке, где хранится пакет.
  6. Отредактируйте эталон .
  7. Отмените режим Распознавание с обучением (на закладке Распознать в группе Обучение установите переключатель в положение Распознавание с пользовательским эталоном ).